Cómo instalar Java SDK y JRE de Sun en Ubuntu Lucid

Viernes, 14 de mayo de 2010 Franco Catrin Dejar un comentario Ir a comentarios

En Ubuntu Lucid se eliminaron los paquetes de Sun para Java desde los repositorios clásicos para dar cabida a la implementación libre de Java openjdk.

Para la mayoría de los usuarios esto no es problema, pero si lo puede ser para los desarrolladores que necesitan trabajar y hacer pruebas con el JDK o JRE de Sun exclusivamente.  Personalmente tuve problemas con el plugin de SVN para Eclipse por este motivo (subclipse).

La solución está a pocos clicks y a pocas teclas de distancia:

Primero hay que habilitar el repositorio Partner de Ubuntu en Sistema -> Administración -> Orígenes del Software -> Otro Software.  Tras confirmar, se actualizará la lista de paquetes disponibles (el mismo sistema lo solicitará).

Una vez actualizada la lista, instalar los paquetes que necesitemos de Sun.  (Los de fonts hacen una gran diferencia al usar aplicaciones Swing)

sudo apt-get install sun-java6-jdk sun-java6-jre sun-java6-fonts

Finalmente configurar el sistema para usar el Java de Sun por omisión:

sudo update-alternatives --config java

Es posible que también se tenga que hacer lo mismo para configurar el plugin de Java

sudo update-alternatives --list mozilla-javaplugin.so

Comprobar con el mismo comando java y la opción -version:

fcatrin@shaman:~$ java -version
java version "1.6.0_20"
Java(TM) SE Runtime Environment (build 1.6.0_20-b02)
Java HotSpot(TM) Server VM (build 16.3-b01, mixed mode)

Categories: Español, Tips Tags: , ,






  1. David
    Domingo, 23 de mayo de 2010 a las 11:51 | #1

    Muchas gracias!!! Eso era lo que necesitaba… no te imaginas la cantidad de errores que se me presentaban a la hora de usar Swing con el openJDK… ahora funciona perfecto :) Muchas gracias!!!

  2. Sábado, 21 de agosto de 2010 a las 13:38 | #2

    Saludos desde el frío Polo Sur :)

  1. Viernes, 14 de mayo de 2010 a las 17:31 | #1